Problems in LHR? My deploy seems to be unreachable

:wave: Hi, I have just deployed (successfully) a new version of an app and it seems that it can’t be reached, every connection times out.
I’ve already tried to restart the app and I can see from the logs that it spins up correctly

2022-03-31T13:35:12.726 app[75e6954a] lhr [info] Sending signal SIGINT to main child process w/ PID 515

2022-03-31T13:35:27.684 runner[75e6954a] lhr [info] Starting instance

2022-03-31T13:35:28.815 runner[75e6954a] lhr [info] Configuring virtual machine

2022-03-31T13:35:28.824 runner[75e6954a] lhr [info] Pulling container image

2022-03-31T13:35:29.269 runner[75e6954a] lhr [info] Unpacking image

2022-03-31T13:35:29.278 runner[75e6954a] lhr [info] Preparing kernel init

2022-03-31T13:35:31.469 runner[75e6954a] lhr [info] Configuring firecracker

2022-03-31T13:35:31.600 runner[75e6954a] lhr [info] Starting virtual machine

2022-03-31T13:35:31.829 app[75e6954a] lhr [info] Starting init (commit: 6f9865f)...

2022-03-31T13:35:31.889 app[75e6954a] lhr [info] Preparing to run: `/cnb/process/web` as heroku

2022-03-31T13:35:31.943 app[75e6954a] lhr [info] 2022/03/31 13:35:31 listening on [fdaa:0:3bc5:a7b:276d:75e6:954a:2]:22 (DNS: [fdaa::3]:53)

2022-03-31T13:35:32.962 app[75e6954a] lhr [info] > backend-node@1.0.0 start

2022-03-31T13:35:32.962 app[75e6954a] lhr [info] > node index.mjs

2022-03-31T13:35:33.792 app[75e6954a] lhr [info] Example Guestbook App listening at http://localhost:8080

I’ve also tried to redeploy it with the same code that works fine locally but nada.

The app is tru-id-guestbook-backend id 75e6954a and is deployed only in London LHR

$ curl -I
curl: (92) HTTP/2 stream 1 was not closed cleanly before end of the underlying stream

Are there any issues in LHR?

All of a sudden it started working now :eyes:
I have a demo of this project tomorrow morning I hope it won’t let me down :smile:

Our state synchronizing “stuff” was bogged down in LHR. We fixed it just now :slight_smile:

Sorry about that :confused:, we’re working towards a more permanent fix.

1 Like

No worries, I really enjoy platform, a bit more stability and it’s perfect :ok_hand:

@Jerome I’m experiencing the same issue with one of my applications - any chance you can take a look please?

I’m looking right now; I don’t see anything weird. What’s the name of your app?

If this is the app you quoted upthread, it looks like it’s only scheduled to run in SEA.

A quick note that we are in fact seeing some network connectivity issues in SEA right now (you can watch the status page for a resolution).

@thomas mine is the app mentioned in my linked post (feel free to continue the discussion there) and it is only deployed in SEA but that should be fine right? Good to see that you’ve noticed a problem. I’ll watch the status page for updates.