Unable to destroy fly volume

I was cleaning up the extra volumes created by the V2 migration and I found a volume that I am unable to destroy.

This volume does not appear to have been left over from the V2 migration; I was able to delete that specific volume. I believe this volume may have been part of a different migration that occurred on Mar 26, 2023 17:00 UTC.

The volume is listed when I run fly volumes list but when I try to delete the volume via flyctl I get an error.

fly volumes destroy vol_pkl7vzkg52zvqg60
Error: failed to get volume vol_pkl7vzkg52zvqg60: not_found: sql: no rows in result set

When I try to view the volume in the Fly dashboard I get the following error:
Unknown issue listing volume snapshots

Maybe running the commands with --debug would provide more helpful information.
Just a suggestion if you haven’t tried already.

Here are the results from running the command with --debug

Error: failed to get volume vol_pkl7vzkg52zvqg60: not_found: sql: no rows in result set
goroutine 1 [running]:
	runtime/debug/stack.go:24 +0x64
github.com/superfly/flyctl/internal/cli.printError(0x140003f7860, 0x14000cd2340?, 0x105d6d2a0?, {0x10614e300, 0x14000cd2340})
	github.com/superfly/flyctl/internal/cli/cli.go:126 +0x2b4
github.com/superfly/flyctl/internal/cli.Run({0x10616a018?, 0x140009eda00?}, 0x140003f7860, {0x14000132010?, 0x4, 0x4})
	github.com/superfly/flyctl/internal/cli/cli.go:84 +0x5d4
	github.com/superfly/flyctl/main.go:47 +0x1a8
	github.com/superfly/flyctl/main.go:26 +0x20

The second part of the error (after the volume ID) seems to be from an API response.
That is beyond what I can help with.
But I am sure someone who can help with that will get to this soon.

@abstractcoder thanks for sharing, specially commenting about the dashboard error, that led us to realize there’s some internal mismatch in our deletion code for your volume and we will be taking a look on that.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.