Postgres "failed to launch VM" EOF

Not sure where to go from here?

$ fly pg create
? Choose an app name (leave blank to generate one): white-pg
automatically selected personal organization: Oli
Some regions require a paid plan (fra, maa).
See to set up a plan.

? Select region: London, United Kingdom (lhr)
? Select configuration: Development - Single node, 1x shared CPU, 256MB RAM, 1GB disk
Creating postgres cluster in organization personal
Creating app...
Setting secrets on app white-pg...
Provisioning 1 of 1 machines with image flyio/postgres-flex:15.2@sha256:caf62aa598b9a4ca63b11f0674239a730aad7091ffa4171a0c9665aba4184ccc
Error failed to launch VM: Post "http://[fdaa:1:7886::3]:4280/v1/apps/white-pg/machines": EOF

Have you tried again, just to rule out an intermittent issue?

Yep, about 3 times yesterday, and once more today.

$ fly logs -a white-pg
Waiting for logs...

Just now on about the 5th go, this worked, about 24h after first trying. What happened here?

Concerned I could start building stuff out on Fly, and then not be able to deploy!

If you run the command again, try setting the log level to debug:

LOG_LEVEL=DEBUG fly pg create ...

This should help provide some additional insight in what might be going on.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.