Error creating PostgresSQL database


I’m experiencing the error when creating PostgreSQL database:

Creating postgres cluster in organization personal

Creating app…

Setting secrets on app imagecollager…

Provisioning 1 of 1 machines with image flyio/postgres-flex:15.3@sha256:44b698752cf113110f2fa72443d7fe452b48228aafbb0d93045ef1e3282360a6

Error: failed to create volume: failed to create volume: invalid character ‘<’ looking for beginning of value

I chose region amsterdam, configuration: Development - Single node, 1x shared CPU, 256MB RAM, 1GB disk

I already added credit card and authentication works just fine

Tried multiple times yesterday and today and still getting the same error.

Can someone help please?


hi @aldm

Are you using any options with the fly postgres create command?


I just fill db name, region and deployment configuration when prompted

Could you try choosing a different region? I can’t reproduce this error, so I just want to gather some info if I can.


I realised it was an issue with by VPN

When I turned it off all works well and DB is created

However, when I try connecting via sql and provided connection string

psql "postgres://<username>:<pass>@<appname>.flycast:5432"

it fails with

psql: error: could not translate host name "imagecollager.flycast" to address: nodename nor servname provided, or not known

flyctl postgres connect -a

works though

This is expected. That connection string is meant for other fly apps only. You can use something like fly proxy 5432 -a <postgres-app-name> to proxy to localhost and connect

Ok thanks.

And I should be able to connect from my app using host .flycast with these credentials, right?

No. You’d use localhost and the port you chose in that command. This proxies the DB to your localhost

But how to I access database from AWS elastcbeanstalk app for instance?

Is it possible at all?

Or I need to have the whole infrastructure on

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.