Postgres machine blocked

Hi, I have been using postgres for two weeks without any problem. Since this morning I receive connection timeout from my application.

When executing > fly pg config -a [app-name] show, I receive :
Error: command is not compatible with this image
When executing > fly pg restart --app [app-name], I receive :
Error: failed to obtain lease: failed to get lease on VM 48ed542b706518: dial tcp [fc01:a7b:10b::]:3593: i/o timeout

Could you tell me how to get unstuck ?
Thanks in advance

Hi there,

I am having similar issues with my postgres app. They have seemed to occur at a similar moment. I have had this issue before however. Previously I was able to just force destroy the machine (fly m destroy <machine_id> --force) and create a new one. However this time I am getting similar timeout errors as you are getting and there seems no way to use any command on the non responding machine.

I have also tried to launch a new postgres instance using a snapshot but I get the following error:
fly postgres create --snapshot-id <snapshot_id>
Error: failed to create volume: failed to create volume: EOF

I was lucky to have made some additional backups.

I would also like to know what is exactly going on.

1 Like

Thanks @thijssimons for the info, I was following the same path but with no luck either. I also wonder what is going on and how to get unstuck. On my side I have no important data yet so I might completely destroy the app and recreate a new one. I still would like to understand how to get out of this in case it happens again in the future.

Same problem here:

Error: failed to create volume: failed to create volume: EOF

…when trying to restore form snapshot.

Hi, just FYI, As I did not have any valuable data yet on the DB, I decided to destroy and recreate it.
I would still be interested to understand what happened though and how to properly get out of this state in case it happens again in the future.

My machine seems to magically have started to respond again. I think it has to do with some local outage but im not sure.

Anyway I am still not able to connect to the app using the proxy,
fly proxy 15432:5432 -a db-app-name:
Error: db-app-name.internal: host was not found in DNS

Gives me the following error.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.