Is credit card details still required even when prepaid credits are purchased?

Hello, after having read the following posts:

It was my understanding that the prepaid credits are an approach to prevent unexpected costs. Thus, I have purchased $25 worth of prepaid credits and expected the platform services to be available to me without requiring me to submit my credit card details.

Then, I attempted to deploy an app on the platform, but my app’s deployment status indicates “pending” and on my account dashboard i am greeted with a message saying a payment source is required.

I’m not sure if the two issues are related, but i suspect they are…

Did I misunderstood how the prepaid credit system works?

Thanks.

You should be able to launch an app in an organization if it has prepaid credits on it. Could you post or DM the app name that’s pending?

Yes, ofc. The app name is " throbbing-fog-867" and the newest status reported in the “overview” panel is “dead”

Also, in my “organizations” panel, I have this type of state where billing reports “SOURCE_REQUIRED”.

Does this still means that platform services are available for my account/organizations

Thank you.

You can use all platform services with prepaid credit. The account status message was wrong. We just fixed it so SOURCE_REQUIRED is only shown if there’s no credit card and no credits.

Your app is showing as dead because it was deployed but was crashing. Looks like there’s an error in the code:

/workspace/app.js:45
  res.status(err.status ?? 500);
                         ^
SyntaxError: Unexpected token '?'

You can see more with flyctl logs

Hi michael, thanks for checking in!
So i adjusted the application code and redeployed. The application itself is working now, but there seems to be a DNS resolution issue. I cannot access the server/VM via the provided URL, but I can access it directly via the IP. So I went over to another workstation and tried to access the URL and still got the same DNS resolution issue. (tried on my phone as well, same, via IP => ok; via URL nope) I also deployed the demo app from the Docs at: Connecting to an App on Fly · Fly . Same issue

No problem we can look into it. Looks like the last app name you posted was deleted, could you post or DM the new app name?

Name of my app deployed => still-sun-6316
Name of app from the Docs deployed => quiet-voice-3433

Thanks for your help
p.s. I can’t figure out how to dm here, maybe you could dm me to let me know

@z.h.m Sorry, I typed up a reply and somehow didn’t hit send. This is fixed now. There was an issue with a few *.fly.dev domains created yesterday afternoon that’s been fixed.


Also, do you see the “Message” button when clicking on my name like in the screenshot below? That’s how to DM, but I’ve heard from a few people that they couldn’t see it, so we might need to change permissions for new forum accounts.
image

1 Like