Indefinitely hanging deploy, can't destroy volumes.

I’m trying to deploy, and hanging indefinitely at

==> Monitoring deployment

v123 is being deployed

Similarly I’ve been trying to destroy a volume, and get:

Error failed deleting volume: unhandled upstream service error: error renaming lv: error creating volume:   Existing logical volume "app_23044_garden_data_20195" not found in volume group "data_0"
: exit status 5

Tried the old trick of destroying the builder, but no luck.

Is this app in ord by any chance? That region is having an issue. That would explain that error, if so:

No, it’s in ams and lax.

Still can’t deploy. Can someone from Fly help me with this? I have no errors to use to troubleshoot this problem with.

The volumes issue appears to be an ongoing issue as that same error has been found by others:

So that one awaits someone from Fly to investigate.

However to debug the deploy-hanging issue, can you try adding a debug log in front? This: LOG_LEVEL=debug fly deploy. That should show a bit more detail about what it can’t do and why it’s hanging.

If that doesn’t reveal anything helpful. these are some other tricks that may help. Of course they won’t make any difference if this problem is at Fly’s end but worth a try while you wait: