fly ssh console fails with `Error host unavailable: host was not found in DNS`

Hey all. Pretty much what the heading says. As of the last few hours I am unable to fly ssh console into a particular app, and just get the error:

$ fly ssh console --verbose
Error host unavailable: host was not found in DNS

I’ve tried scaling up the app, triggering a new deploy, etc., and nothing fixes it. I am however able to ssh into other apps, just not this one.

Of note is that I moved 3 apps from my personal account to an organization. Could this be a contributing factor? However, I’m still able to access the other 2 apps I moved (PG & Redis). I don’t think I’ve restarted them since moving them, so that might the difference?

fly status suggests the app is happy:

  Name     = my-app-name
  Owner    = my-org-name
  Version  = 5
  Status   = running
  Hostname =

Deployment Status
  ID          = fc6b8503-e9ed-662f-10e2-612718ef3464
  Version     = v5
  Status      = successful
  Description = Deployment completed successfully
  Instances   = 1 desired, 1 placed, 1 healthy, 0 unhealthy

I am also able to access the app via HTTP, so it really does seem to be 100%.

1 Like

(from fly ssh console not working - #6 by kurt)

See if it works if you can ssh into an active instance (vm) by specifically asking to connect to it.

# find active vms
fly ips private

# choose an active vm
fly ssh console -s

Thanks, just tried this. fly ips private works and returns:

  ID       | REGION | IP
4596d999 | fra    | some-long-ipv6-address

However, fly ssh console -s doesn’t work:

Error look up owl-commander: failed fetching instances for "my-app-name":
can't find deployed regions for my-app-name

I’ve since had this resolve itself. I set a new secret and the next time I tried to connect it worked :man_shrugging: Not sure if that was the trigger or it was just the passage of time; I wish I’d tried to connect again just before setting the secret, but will do so if I see it again.

1 Like

Neat! Fly’s internal DNS has been going through quite a few road bumps, of late.

Btw, I almost sent a pull-request for flyctl to let its users ssh into a vm using private ip and as fate would have it, this is already supported (code).

For future:

$ flyctl ips private
  ID       | REGION | IP                                
  ddddeeee | aws    | fdaa:0:aaaa:bbb:cccc:dddd:eeee:2  

$ flyctl ssh console "[fdaa:0:aaaa:bbb:cccc:dddd:eeee:2]"

Thanks, fly ips private was a rather useful command to learn, so I appreciate your responses!

1 Like

Hi, is this issue has been totally fixed?

fly ips private returns an empty list for me. In the console (web) it shows me that one builder is running, so shouldn’t at least that show up?

1 Like

This seems to happen for apps on a custom private network. I can ssh into my default network without issue. Any apps outside the default network are inaccessible.