Unable to find the deployed app at .fly.dev DNS address

Hey again, somehow I immediately ran into a new error that I really can’t find an obvious explanation to :sweat_smile:.

Just now, I’ve deployed my app (the same one as in Unable to find Dockerfile - #3 by teemu) but for some reason I can’t seem to resolve its DNS address https://realtime-multiplayer.fly.dev/ and Chrome just throws ERR_NAME_NOT_RESOLVED

I wonder what I am doing wrong here? Tried adding all kinds of ports and using ‘’ for hostname but still the DNS address doesn’t work.

Make sure the [[services]] section of your Fly app is non-empty (ref).

You can allocate IPs for your app with flyctl (exec’ing which should auto add approp A / AAAA records for <app-name>.fly.dev): flyctl ips allocate v4 · Fly Docs | flyctl ips allocate v6 · Fly Docs

I am also having problems after deploying a small code change to a previously working app. No changes to deployment configuration. The app was there before the deployment and now the DNS does not resolve.

All other apps in my org are working correctly. Just the one that I redeployed is unreachable.

I have tried multiple redeploys, scaling to 0 and and then scaling back to 1 instance. Nothing is working. The logs show the app startup and listening on the correct port. DNS and certs are all in order. No request resolves to the service though.

I have [[services]] section but haven’t allocated an IP address. Thought I wouldn’t need one for hobby tier app? I followed the instructions in the example guides and as far as I know, it should work.

Hey, any help on this? Anyone know what to do, contact customer support? I don’t know how to debug this.

You do need an IP address. At least until we have shared IP addresses.

We don’t create a DNS entry if there are no IPs.

Huh that fixed it, thanks a lot! Should probably add a debugging section about this though in the Nodejs guides. Hopefully @macdrich you got your problem also sorted out.

Hey, any chance you could share exactly what you did to resolve this? I’m having the exact same issue you describe and can’t get it sorted. Seems like it should just work and it’s weird that the basic usage example doesn’t work out of the box.

Create an IP address eg flyctl ips allocate-v4

i am running into this issue, ive deployed my site through fly.io and it said everything worked however when I open the site it says the server cannot be found, any fix?