Error failed moving app: This feature is not available for Postgres apps at this time

$ fly apps move vxu-pg -o vxu
INFO app "vxu-pg" is currently in organization "personal"
Moving an app between organizations requires a complete shutdown and restart. This will result in some app downtime.
If the app relies on other services within the current organization, it may not come back up in a healthy manner.
Please confirm whether you wish to restart this app now.
? Move app vxu-pg? Yes
Error failed moving app: This feature is not available for Postgres apps at this time

I was able to move a different postgres app to another organization, but when I try and move this one I get this error. Any chance I could get more information on this?

The PG implementation that your app is using does not yet support this feature. When you move across organizations you’re moving into a new private network where each Machine ends up with a new IP address. It’s a bit of a delicate dance to ensure the cluster gets reconfigured correctly, but it’s something we do hope to have fleshed out in the near future.

In the short-term, you could consider provisioning a new PG from a snapshot, or leveraging the fly pg import feature to move your data over.

I am trying to shrink the volume as well, so the snapshots won’t work but thank you for suggesting pg import. When I try and use fly pg import from another organization, it says hostname resolving error.

I have tried these two variations.

fly pg import postgres://username:password@oldapp.internal:5432/database --clean -a new-app
fly pg import postgres://username:password@oldapp.flycast:5432/database --clean -a new-app

I’m pretty sure I’m just referencing the other machine’s hostname wrong, but I’m not sure how I should reference it :confused:

Update 1: Also tried using proxy and localhost. Says the db doesn’t exist even though I’m looking at it in DataGrip. Also tried --clean --create

Update 2: Its also probably a good idea to kill the machine if the import fails? I just had to delete the old ones because I hit the 20-machine limit.

Update 3: connecting from my terminal with the same connection strings connects without a problem. I think there’s a bug with pg_import too

@shaun any advice?



Does the “new app” already exist?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.