Apps not deploying keep on tryting on push image

AS described in the title, even with applications that have always worked and just had to change a string .

I get this too, and infact am getting it night now also.

I previously raised a topic that got no traction here: Can't deploy to to SJC when builder is in SYD

Since I’m trying to deploy to a non-production server I changed it’s region to syd and tried again, that didn’t help. I tried deleting the builder again and that didn’t work either.

I did find this recent topic though talking about large images being a problem: Can't Push Images in the Morning

Mine that is failing is 312mb, and whenever I have this problem it’s always that one.

Well in my case, i simply updated one image … even that one didn’t work, when I say upload, I just changed a string which was the address to my bucket

I’ve managed to fix my situation by setting up a Tailscale exit node in SJC and while using that deleting the builder and starting a new deploy. This caused for me the builder to be created in SJC rather than SYD and my deploy when through fine.

Found this handy guide for doing that: GitHub - patte/fly-tailscale-exit: Run a VPN with global exit nodes with, tailscale and github!