Unknown error occurred with flyctl postgres create

Hi,

I’m having trouble creating a postgres cluster in any region. I’ve tried multiple regions such as lax, sea etc but it has the same error

> LOG_LEVEL=debug flyctl postgres create
DEBUG Loaded flyctl config from/home/gp/.fly/config.yml
DEBUG Working Directory: /mnt/c/Users/gp
DEBUG App Config File:
? App name: postgres-gp
DEBUG --> POST https://api.fly.io/graphql {{"query":"{ organizations { nodes { id slug name type } } }","variables":null}
}
DEBUG <-- 200 https://api.fly.io/graphql (768.96ms)
Automatically selected personal organization: <removed>
DEBUG --> POST https://api.fly.io/graphql {{"query":"query { platform { requestRegion regions { name code gatewayAvailable } } }","variables":null}
}
DEBUG <-- 200 https://api.fly.io/graphql (682.34ms)
? Select region: sin (Singapore)
DEBUG --> POST https://api.fly.io/graphql {{"query":"query { platform { vmSizes { name cpuCores memoryGb memoryMb memoryIncrementsMb priceMonth priceSecond } } }","variables":null}
}
DEBUG <-- 200 https://api.fly.io/graphql (586.93ms)
? Select VM size: shared-cpu-1x - 256
? Volume size (GB): 10
Creating postgres cluster postgres-gp in organization personal
DEBUG --> POST https://api.fly.io/graphql {{"query":"mutation($input: CreatePostgresClusterInput!) { createPostgresCluster(input: $input) { app { name } username password } }","variables":{"input":{"organizationId":"G1B7JG6wPDBq0I8b8yRl4q9RlQUVg7","name":"postgres-gp","region":"sin","vmSize":"shared-cpu-1x","volumeSizeGb":10}}}
}
Launching...⣻ DEBUG <-- 500 https://api.fly.io/graphql (1.02s)
Error An unknown error occured.

Sorry about that! A fix for our backend is being deployed now, I’ll follow up once it’s out.

Thanks for the fast reply! I’ll try again when your fix is up

@geraldpng the fix is out now, sorry for the delay

Just tried it out and it works. Thanks!

2 Likes