unable to deploy after suspend/resume (solved)

i had a problem, it is not actual anymore, but i thought it might the fly-io developers maybe in some way:

  • i had an app (the one where i write a custom dockerfile)
  • everything worked fine
  • i used “flyctl suspend”, then “flyctl resume”
  • afterwards it was not possible to do “flyctl deploy” . the deploy
    never finished, the app was “dead”
  • i tried many things, and something helped, i’m not 100% sure which
    thing helped, but most probably it was that i used “flyctl scale” to
    scale it to a single instance (it was a single instance before too),
    and that seems to somehow switch things back to normal, afterwards
    things worked ok

Thanks for pointing this out. I’ll test it out this week and fix whatever was preventing deploys after resume.

Extra data point, I experienced the same issue with a go project too. I can confirm that my fix was manually setting the scale count to 1 (prior it was showing as 0) using flyctl scale count 1.

Resetting the scale worked for me also, thanks for the tip!

I experienced this as well for on an app that’s been running continuously on fly for months. I was experiencing an attack so I suspended the app and could not resume it-status was “dead”. Redeploying it did not work until I set scale count to any value. I tested this a few times with the same results.