Can't deploy. Can't scale. "No deployment available to monitor"


I’ve been using fly for months and everything was working fine. In the last few hours I can no longer redeploy my apps. If I run “flyctl deploy” I get all the way to the “Monitoring deployment” state and then get the following error “No deployment available to monitor”.

I’ve also tried running “flyctl scale count 0” which does not throw an error, but never scales my application down.

Additionally, when I try to deploy, I can see a new version “Released” in the activity panel of the UI, but when I go to the monitoring tab under Allocations, I still see the old version running.


The same thing is happening to me. It sounds like it’s running the release command 3 times and then timing out. (I’m using fly deploy --remote-only)

I also tried running fly deploy --strategy immediate, but it didn’t help, neither fly restart.

I also see the new version release in the activity page, but I’m pretty sure it’s running the old code.

Sounds like an incident happened yesterday related to that: Status - New app deployments are broken due to exhausted IPv4

Does anybody know if it’s still happening?


@lucasprag I’m seeing exactly the same and hoping it’s just temporary.

Heyo! We’re looking into this. The deploy monitoring is what our CLI uses to show you status of deploys. The deploys are happening as expected, but something is making some apps slow to get status updates.


@kurt I don’t think this is true. The code I’m trying to deploy changed a bunch of metrics I’m sending to datadog. I’m not seeing any new metrics and I’m still seeing ones that I removed coming through.

It seems like fly is still running the old version of my code.

1 Like

I can confirm :point_up: I changed a few things in my templates and the previous HTML is still there.

1 Like

Alrighty, we’re still investigating.


Thank you @kurt :raised_hands:


This is happening to me too! The Fly dashboard reports the release as being successful but I see

==> Monitoring deployment
Error 1 error occurred:
	* No deployment available to monitor

And when I SSH into the machine, the old code is still there.

I was just working through this same thing. fly status shows a release from a couple days ago. It looks like it might corresponding to this partial outage, though it hasn’t come back.

CleanShot 2022-10-28 at 14.39.47

I subscribed to incident notifications so hopefully we’ll hear something positive soon. :slight_smile:

Sounds like things are starting to clear out. I was able to deploy twice to just to confirm it :+1:

Thank you @kurt and team :raised_hands:

1 Like