App status appears as "Dead" after restarting

Hi, earlier today I ran flyctl restart [app-name] and since then my app’s status has not changed from “Dead”. I’ve tried redeploying, restarting and also changing the restart_limit to 0 (as suggested here: Can't bring app back from the dead). But I’m not able to deploy this change while the app is dead.

If I run flyctl logs I see no updates since the restart from this morning. If I run flyctl status --all -a [app-name] all instances listed show a restart count of 0- and all health checks as ‘passing’.

Is there something else I can try? Thanks.

Hi @DaniBZ !

Can you share your app name (feel free to do so in private messages if you want), and your current fly.toml?

Right now there’s a scheduled maintenance happening (read more here) so if your app is single-instance only there might be some downtime.

What’s the feedback you get from running those commands via flyctl?

Can you share the output of this?

Sure flyctl status --all -a [app-name]

xxxx app 193 lhr stop complete 1 total, 1 passing 0 3h55m ago
yyyy app 192 lhr stop complete 1 total, 1 passing 0 4h17m ago
zzzz app 191 lax stop complete 1 total, 1 passing 0 2022-07-15T14:55:38Z

From your toml I can see that internal_port = 3000, is your app listening to that port? If not your health checks might not be passing

Yes its listening on that port, but we cant keep the app alive long enough to see anything in the error logs.

I can see that y’all edited your config and it seems to be working now, would that be correct?

For some reason, the app was scaled to 0, scaling it back to 1 and changing the config to remove auto rollback seem to resolve the issue.

1 Like