Unable to create or delete Redis instance

I’m unable to create a new Redis instance because it says I already have one. I cannot delete the Redis instance because it says database not found. I log into Upstash and it doesn’t show any Redis databases.

Here’s my interaction with the CLI:

(base) ➜  blurbsocial git:(master) ✗ fly redis create
automatically selected personal organization: Joey Robert
? Choose a Redis database name (leave blank to generate one): blurbsocial-redis
Some regions require a paid plan (fra, maa).
See https://fly.io/plans to set up a plan.

? Choose a primary region (can't be changed later) Toronto, Canada (yyz)

Upstash Redis can evict objects when memory is full. This is useful when caching in Redis. This setting can be changed later.
Learn more at https://fly.io/docs/reference/redis/#memory-limits-and-object-eviction-policies
? Would you like to enable eviction? Yes
Some regions require a paid plan (fra, maa).
See https://fly.io/plans to set up a plan.

? Optionally, choose one or more replica regions (can be changed later): 
? Select an Upstash Redis plan Free: 100 MB Max Data Size, ($0 / month)
Error: input:3: createAddOn You may only provision 1 Free plan per organization

(base) ➜  blurbsocial git:(master) ✗ fly redis list
blurb-redis	personal	Free	Disabled	yyz           	            	

(base) ➜  blurbsocial git:(master) ✗ fly redis destroy blurb-redis
Destroying a Redis instance is not reversible.
? Destroy Redis instance blurb-redis? Yes
Error: input:3: deleteAddOn database not found

Have you ever tried to delete the blurb-redis DB before? It looks like a left-over record in our system, and I’m looking into how to fix this up.

If you need a redis instance urgently, you can create a new non-free instance or create a second org.

1 Like

Thanks. I created it like 6 months ago and I don’t recall if I tried to delete it then, but I tried to delete it today after coming back to fly.io and trying to re-provision a redis instance. Not urgent, exploring the platform and hit this early snag. Leftover record sounds correct.

We’ve deleted it for you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.