Deleted Upstash Redis Database From Account Settings; Now Cannot Make New One

Hello! I was having trouble with my Redis configuration, so I tried to start fresh.

I deleted my database from my account settings and then I realized it was still visible in my terminal when I entered flyctl redis list.

I tried deleting it from the terminal as well, but fly redis delete <ID> returned Error input:3: deleteAddOn Could not find AddOn.

Then, I tried to create a new database with flyctl redis create.

This returns Error input:3: createAddOn You may only provision 1 Free plan per organization.

Am I out of luck? Or is there a way to provision a fresh Redis DB for my personal project to test out the fly platform?

Is this still failing for you? If I found the correct organization, I don’t see any addons on that organization so its possible it was just delayed unprovisioning your first redis.

Could you share some more of the arguments or prompt responses you’re passing to fly redis create or delete? The Error input:3: makes me think it’s possible something else is happening.

Note that you need to pass the DB name (from fly redis list) to fly redis delete, not the ID.

Thank you for this information, @jsierles – in the documentation, it looks like the ID is used:

But you’re right, when I used the name instead, it was deleted.

Unless I’m reading the docs wrong, maybe something needs to be edited there. In any case, thank you for the help!

Doh, docs need updating. Thanks!