The multi-region application does not work in one region.

I have a simple Redis app in 3 regions (lhr/syd/ord). And I couldn’t connect to my app in ord region today. I tried to stop and start the app again:

fly scale count 0 -a sxt-dev-redis
fly scale count 3 -a sxt-dev-redis --max-per-region=1

But the app works only in 2 regions.

I tried to deploy again… and the same result - only 2 instance.
Could you check and help me? It’s important. I had the same problem with my app. Changing ENVs doesn't redeploy apps

but this is a simple Redis app…

looks like the problem in ord because I can’t deploy one instance

I’m looking at this, I’m not sure why your VM in ord isn’t being scheduled yet though.

We’re still troubleshooting this. You can workaround it by creating a new volume in ord and then removing the old ord volume if you’d like.

So I’ve already done it. I’ve deployed to lhr/syd and it’s ok. But sxt-dev-redis-ord still can’t be deployed

I don’t see a new volume created for that app. Do you want me to create one for you?


We fixed the issue with sxt-dev-redis and it’s now running in Chicago. I just now realized you were looking at two different apps, and the -ord one seems to be running as well.

Yep. I’ve tried to deploy the Redis app in another app. Looks good! Thank you.

One more question: What was the problem? Could this happen again in the future? I would not like to have any problems with the production app.