Spring App automation with fly.io

Hello, I’m trying to deploy a spring boot app with CI/CD but is not working.

I think i’m stuck with the login. I tried to login with Access token but is not working.

I tried flyctl auth login -t <access-token> but it open the browser and the automation is unable to click on “continue” from the page.

I tried to full login with secrets like this : flyctl auth login --email <my-mail> --password <my-pass> --otp <otp> and it seems to work. I run an flyctl apps list and it display all of my app.

But, when I launch the deployement with flyctl deploy -a <my-app> I have a docker connection issue

To be sure, I change my job to run flyctl auth whoami and it only display ******* so I’m not sure that I am correctly logged in.

Just for information, I’m using Jetbrains Space automation.

  1. Generate a auth token (either from the Fly.io dashboard or using flyctl auth token).
  2. Set it as FLY_API_TOKEN in your CI/CD secrets / vault.

Ref this doc entry which is for GitHub Actions, but i imagine the steps aren’t too dissimilar to JetBrains Space Automation.

The problem came from the wireguard.
I solved the issue with these two commands.

flyctl wireguard websockets enable
flyctl agent restart
1 Like