Deploying remix/run blues-stack app, docker/login-action@ fails: Error response from daemon: login attempt to failed with status: 401 Unauthorized

I’ve uploaded the required variables to a deploy environment on GitHub. I’m not sure if the docker/login-action@ action should have the FLY_API_TOKEN as the value for the password field, or the password of my actual account. Also, I haven’t been able to confirm wether or not the action receives the username and password arguments from its environment. Nevertheless, all deploys fail. How do I debug this situation?

Hi! What are you using for the username? The registry should accept the placeholder x for the username and your API token for the password. (It doesn’t accept your account email or GitHub username, which might be part of your problem.)

AFAICT this isn’t officially documented anywhere. That might be because we have flyctl auth docker to set up Docker authentication for the registry automatically. If possible, I’d recommend this method. (In case you’re not already aware, there’s a GitHub action to set up flyctl in your workflow.)

(For the curious, this is the flyctl code that does this. You can see it using x and your API token.)

Thank you so much for the response, I tried running with my registered e-mail/ username.