[Solved] Destroying an app returns 500/unknown error occurred error

#flyctl destroy hidden-moon-3389
Destroying an app is not reversible.
? Destroy app hidden-moon-3389? Yes

Error An unknown error occured.

Doing the same over the web interface responds with HTTP 500 instead.

I noticed this issue after the following steps. The app was fairly short lived.

  1. Had another app by this name which got stuck on a deployment after I tried a couple of different deployment strategies (i.e. flyctl deploy would still work but the logs stayed at
    2021-11-12T19:21:39.202306937Z app[7658fbc5] fra [info] Sending signal SIGINT to main child process w/ PID 510
    2021-11-12T19:21:40.204743262Z app[7658fbc5] fra [info] Main child exited with signal (with signal 'SIGINT', core dumped? false)
    2021-11-12T19:21:40.205015420Z app[7658fbc5] fra [info] Starting clean up.
    and I never saw another line come out from the logs.
  2. I flyctl destroyed the app, which went successfully and flyctl apps created the app with the same name again;
  3. I deployed the application again a couple times;
  4. I ran flyctl destroy again, leading to the current situation where I’m unable to destroy the application in any way.

Does it still fail if you try to delete the app again? From our logs it looks like a temporary network issue connecting to a backend system is the culprit.

This was a bug in our app deletion process, it should be fixed now.

Yeah, was able to destroy/delete the app today. Thanks!