Trying to delete a builder app returns "500: Server error"

Hello !
I tried from the web interface to delete the builder app, it failed with error 500.
I also tried to delete with fly command, here’s the output:

mad@dev > LOG_LEVEL=debug flyctl destroy fly-builder-restless-dawn-9023
DEBUG Loaded flyctl config from/home/mad/.fly/config.yml
DEBUG Working Directory: /home/mad/code/elixir/project
DEBUG App Config File: 
Destroying an app is not reversible.
? Destroy app fly-builder-restless-dawn-9023? Yes
DEBUG --> POST {{"query":"mutation($appId: ID!) { deleteApp(appId: $appId) { organization { id } } }","variables":{"appId":"fly-builder-restless-dawn-9023"}}
DEBUG <-- 500 (4.54s) {"status":500,"error":"Internal Server Error"}
Destroyed app fly-builder-restless-dawn-9023

Well that’s a pain. There’s a bug that’s entirely unrelated to your builder causing that problem. The fix is rolling out now, I went ahead and deleted your builder for you.

1 Like

Thank you @kurt !

The main reason for me to delete it was that it does not pick the latest version of my recently pushed docker image, is there a way to force the build to renew that cache ?

Was this an image you pushed to Docker hub or somewhere else? And are you referencing it with a tag in a build?

Yes it’s an image pushed to docker hub, the image is referenced as :latest in my docker build file and the image have a ENV REFRESHED_AT=2021-09-30 declared.

:latest is trouble for this reason, but you can use the --no-cache flag on flyctl deploy to build from scratch. Sounds like it might help.

1 Like

Thank you @michael !
I’ll try that --no-cache flag next time I notice that !

1 Like