I can't delete my apps

I made basic apps from following the go example tutorial. I’d like to delete them but I can’t. I have no information as to why I can’t delete them. I get the following error:

upstream service is unavailable

I’ve tried logging in and out of the account.
No idea what to do.

ALSO I can’t delete my account until I delete these apps. Very, very frustrating.

I checked https://status.flyio.net/ no reported outages

Now when I try to delete the app, I’m getting


Hey @sean, can you try again now? I manually deleted your volume, that’s what was holding it up.

Your volume wasn’t created properly and put it in a weird state. That’s not a great experience, sorry about that.

Hi Jerome, thanks for deleting the volume. Do you mind also deleting the remaining builder? fly-builder-empty-hill-8407

I get the same nats error when I try to delete it.

I just deleted it.

Hi Jerome, thanks for you help, I really appreciate it!

All the best,

Hope you give us another try soon! Looks like you fell on a pretty bad edge case (partly caused by me, hehe :confused:).

Usually things “just work”. Without the volumes though, the builder wouldn’t have worked. Same for your app which had a different volume, also in a bad state.

No worries, I think I just got unlucky.