Good old failed to fetch an image on deploy

In the past 3 days I’ve been struggling again with an old friend:

------  > [internal] load build context: ------ 
Error: failed to fetch an image or build from source: error building: failed to solve: rpc error: code = Canceled desc = grpc: the client connection is closing

The usual tricks adding --local-only or --remote-only, destroying the builder and upgrading flyctl haven’t solved it yet for me.

Hey there,

Thank you for sharing that error! I want to ask, do you mind sharing what came before the grpc error in the stacktrace? Also what OS are you on and what is your Docker version? You can run docker version to find out.

Through most of the research/articles I have seen that consist of this issue, they are mostly resolved by:

  1. Restarting your computer
  2. Updating your computer
  3. Updating docker version

A side question: Is your flyctl version up to date?

1 Like

I kept running it a few times over the following few hours with no change and eventually it went through.


Keep us updated, if there are any changes pertaining to this issue!

Now looking to deploy a new version and getting again the same issue. The partial error message is now:

WARN Failed to start remote builder heartbeat: failed building options: failed probing "personal": context deadline exceeded.

Error: failed to fetch an image or build from source: error connecting to docker: failed building options: failed probing "personal": context deadline exceeded

The issue above was using --remote-only, I ran again without it and it worked fine. I don’t know if just unstable or actually due to that change.

If you are still experiencing this issue, I would suggest to run flyctl wireguard reset and see if that resolves it for you. This should help kick the flyctl client into gear and give it a reboot, since it seems it’s having trouble reaching your organization’s wireguard VPN.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.