Can't build remotely (flyctl deploy)

Currently, running flyctl deploy --remote-only fails like this:

==> Verifying app config
--> Verified app config
==> Building image
WARN Failed to start remote builder heartbeat: failed building options: failed probing "my-app": context deadline exceeded
Error failed to fetch an image or build from source: error connecting to docker: failed building options: failed probing "my-app": context deadline exceeded
  • my-app itself seems to be running fine.
  • deleting the existing builder project and re-running the deploy had the same result

I’m currently re-running the deploy using a local builder.

Has anyone got tips on debugging build/deploy failures like this?

flyctl deploy --local-only worked.

Hey there,

I’m assuming, in this context, my-app is the fly-builder-... app, correct?

Can you run flyctl doctor? It might show some issues.

Same thing happened with me around 3-4 days back! but I fixed it using:

fly wireguard reset
1 Like

I done that when it happened with me previously! but it didn’t show anything except PASS.

Here is the detailed info/log that I traced before:
[URGENT] Contact Lost with instance - Questions / Help -

No, I think my-app may actually have been the organization name??