flyctl postgres create - Error Can't create volume, application is already using 1 of 1 zones in iad

Hi there!

Digging deeper into Fly and really enjoying it! I did run into a hiccup trying to create a new Postgres cluster. Sorry if this is a dupe but couldn’t find a similar question on the forum or docs. I’m seeing this:

> flyctl postgres create
? App name: <intentionally blank>
? Select region: iad (Ashburn, Virginia (US))
? Select VM size: shared-cpu-1x - 256
? Volume size (GB): 10
Creating postgres cluster  in organization <org>
Launching...⣯ Error Can't create volume, application is already using 1 of 1 zones in iad

Next, I tried a different region and the cluster deployed correctly. Odd! Not sure what “application is already using 1 of 1 zones in iad” means - I don’t have another app deployed in this region under the same organization.

Thanks!

That is a bug for sure, that happens when it can’t provision a new disk on a separate hardware stack. I just checked and it should be working in iad, will you give it another try?

1 Like

Absolutely, will give it a shot right now.

For future deployments, is it better for me to use flyctrl postgres create or provision from a new fly init of GitHub - fly-apps/postgres-ha: Postgres + Stolon for HA clusters as Fly apps. ?

flyctl postgres create is better, but only because it hooks the cluster up so you can do things like flyctl pg attach to automatically connect apps to it. Otherwise, it’s the exact same thing.

1 Like

Nice, yeah it’s super convenient.

Just tried another deployment to iad - looks like it’s working!

Thanks for these quick replies. I know this sort of support workload can be draining, but it gives me a lot of confidence to use fly over other providers.

No problem! It’s easy, really, we like talking in here.

1 Like