flyctl keeps on asking for a credit card although I provided one already

I just registered on via my github account.
When trying to deploy the test app (hellofly) the system keeps on asking for a credit card.
I enter the data concerning the credit card and the system accepts it (it is not a payment card and the green tick appears). However flyctl continues to show an error and asks for the credit card or buy credit.
Do I have to buy credit also if I am on the hobby plan and will probably never go out of the free allowances?

1 Like

I have the same issue. Although I did not register my account via Github but Heroku through this page.

I get the following error:

Your organization did not setup a payment method.
Fly will only bill you if your account usage exceeds the free tier.
Click here to add a payment method then you will be redirected back here

I have provided my payment details three times now but it still will not deploy. I do not get redirected back to /launch/heroku/ and in my dashboard front page I have also tried clicking on

Trial Plan

Add a payment method to unlock more free allowances.

as well as “Add credit card” in /dashboard/personal/billing to “add a payment method”.

Nothing happens!

1 Like

I am having the same problem.

The problem now appears at solved.
I could finalise the registration and activate a new app.

Further info in this similar thread: My credit card is not being added to my account - #7 by lucamanu