.fly.dev link not working FastAPI gunicorn

Here are my status are logs:
1log.log · GitHub

I’ve allocated 1 ipv4 and v6, tried rebooting manually, etc, nothing works

curl of the ip, or url gives

curl: (56) Recv failure: Connection reset by peer

This exact config works perfectly on my production version, i was even looking for ways to disable it for prod.

Edit: seeing dns problems in fly status, idk if its related but none of the issues so far seem dns related, as ive also tried direct ip access

Hi @preciouso, from the link you provided it looks like you have a single VM running on this app with process group "web", but the services block in your config applies to process "app". If this is right, changing the services to your "web" process group should help.

1 Like

I just realized this :sweat_smile:. I spent hours last night on this.

Side note: Do you know how to remove the unused web ?

1 Like

I’m not 100% on Nomad process group behaviour, but if you don’t want the web instance I think you’d scale that process to zero with fly scale count web=0 (docs), and for good measure remove the processes block from your config file. (edit: you know this already, but run fly deploy to apply your local config file changes :smile: )

1 Like

It tells me invalid vm group. It’s not show as running in the monitoring section, so as long as I dont get charged I think ill ignore it as a UI issue. I don’t expect it to be a security risk

Hm, yes, if fly status only shows you one VM on your app, you should be confident there is only one. I suspect the dashboard is showing you the config for all the processes you’ve defined, even if some of the processes currently have zero instances provisioned.

fwiw, I think process groups will be more straightforward in Apps V2.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.