Getting Recv failure: Connection reset by peer on one app (v2), not the other

I deployed the same apps twice, the same way, one for prod one for staging.

Here is my process:

  • terraform to create app, ip, certs, machines
  • upgrade metadata of the machine to set fly_platform_version to v2 so I can run fly deploy
  • deploy using fly deploy -a <app-name>

I’m deploying the same code (just some env vars changing) on two apps. They do have different resources (staging I tried 256MB and 512MB, prod is 1024MB)

On the staging one, I’m getting many “Connection reset by peer” while trying to curl a simple endpoint

curl: (56) Recv failure: Connection reset by peer

Some queries work, but many don’t.
On prod, no issue at all.

I’ve tried the curl using

  • a custom domain in HTTPS
  • the domain in HTTPS
  • the IPV4 IP in HTTP

I can’t query with curl in IPV6 (for the staging & prod app) so I can’t really say but it doesn’t seem to be the issue

How can I debug? I can give more information if it can help.

Hi @noe-converse
Do you see anything in the staging app logs?

No, nothing!

Can you share the logs for the moment when the app starts and you are doing a request to it, please?

I don’t have a copy of the logs when it was buggy but I have just destroyed everything and recreated every resource through terraform (thank god it was staging having issues and not prod) and it looks like I don’t have the connection reset by peer error anymore for now…

Will be very careful during the next few days and let you know!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.