Failed to create A records.


I haven’t been able to access the site I created for about a week. During some update there must have been some issue creating the A record for it. I tried destroying the app and waiting it out to see if it would resolve on its own, but it doesn’t seem like it. Here’s what the doctor says:

Testing authentication token... PASSED
Testing flyctl agent... PASSED
Testing local Docker instance... PASSED
Pinging WireGuard gateway (give us a sec)... PASSED

App specific checks for tileset-explorer:
Checking that app has ip addresses allocated... PASSED
Checking A record for Nope
	These IPs are missing from the A record:
	This likely means we had an operational issue when we tried to create the record.
	Post in or send us an email if you have a support plan, and we'll get this fixed

There isn’t much I can do other than use another name, but that’s not a good solution.

Hello, it doesn’t seem like your app has an IP address assigned. Running flyctl ips allocate-v4 --shared should fix your issue.

1 Like

Hey @Donitz, this was actually an issue with our DNS server when the app is missing IPv6 records. I’ve deployed a fix now, you should be good to go.

Thank you! Now it works.

If I were to guess, the cause was because of my workflow of destroying and re-creating the app from scratch during updates, which probably messed up the state in some way.

I’ve updated my deployment script now so I only update the existing machine, not destroy the entire app.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.