Deploying Remix with defaults: stuck at load metadata for

Steps followed:

  1. npx create-remix@latest # Select as deployment target
  2. fly launch
  3. Select a region (tried iad and ewj) and deploy now

Gets stuck at:

 => [internal] load metadata for                                  7.8s
% fly launch
An existing fly.toml file was found for app [APP ID]
App is not running, deploy...
Deploying [APP ID]
==> Validating app configuration
--> Validating app configuration done
TCP 80/443 ⇢ 8080
Remote builder [BUILDER ID] ready
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.12 linux x86_64
Sending build context to Docker daemon  99.78kB
[+] Building 30.0s (3/3) FINISHED
 => CACHED [internal] load remote build context                                                           0.0s
 => CACHED copy /context /                                                                                0.0s
 => ERROR [internal] load metadata for                           30.0s
 > [internal] load metadata for
Error error building: failed to solve with frontend dockerfile.v0: failed to create LLB definition: failed to do request: Head "": dial tcp i/o timeout

Hi @bcjordan

Looks like there was a timeout getting the node:16-bullseye-slim docker image. Is this issue still occurring?

It looks like you’re using the remote builders, so one possible workaround is to build locally by passing --local-only when running fly deploy

Possibly some network issue on the remote builder? Still get that timeout this morning.

Yeah separately tried local building on macOS/M1 — that successfully downloads the node:16-bullseye-slim fine but gets stuck on a later npm install step due to out of memory error.

 => ERROR [deps 4/4] RUN npm install --production=false                                                   0.3s
 > [deps 4/4] RUN npm install --production=false:
#12 0.234
#12 0.234 #
#12 0.234 # Fatal process OOM in Failed to reserve virtual memory for CodeRange
#12 0.234 #
#12 0.234
#12 0.234 qemu: uncaught target signal 5 (Trace/breakpoint trap) - core dumped
#12 0.236 Trace/breakpoint trap

Building on M1 Macs has some known problems.

Pasting 2 links for quick reference, but there’s loads of this all over the forum from the past few weeks.