Cannot deploy due to Docker error

When deploying my app, I see:

 => copy /context /                                                                                                                                                                                             1.4s
 => ERROR [internal] load metadata for docker.io/library/node:16-alpine                                                                                                                                        51.0s
------
 > [internal] load metadata for docker.io/library/node:16-alpine:
------
Error failed to fetch an image or build from source: error building: failed to solve with frontend dockerfile.v0: failed to create LLB definition: failed to do request: Head "https://registry-1.docker.io/v2/library/node/manifests/16-alpine": dial tcp 52.72.252.48:443: i/o timeout

I assumed it could be full storage on my remote deploy box, since that frequently fills up, so I deleted it and tried again. Same error.

Haven’t hit this before and no recent changes to my toml or application.

Note I am deploying with --remote-only

It looks like docker hub is timing out for the builder. Retrying should help.

We just rolled out a docker hub mirror to help mitigate these types of issues. What’s the name of your builder? I want to see what region it’s in and what version of the builder it’s using.

Thanks! My builder is fly-builder-restless-breeze-191

Sorry for the trouble. We’re looking into some networking issues in Seattle. You can watch here for updates. Fly.io Status - Connectivity failures in the Seattle region