Autoscale disable not working?

Setting autoscaling to disabled appears to have no effect either in CLI or using GraphQL API.

CLI

> flyctl autoscale disable
     Scale Mode: Disabled

> flyctl autoscale show
     Scale Mode: Standard
      Min Count: 1
      Max Count: 3

> flyctl releases
VERSION STABLE  TYPE    STATUS          DESCRIPTION                             USER                    DATE                 
v47     true    scale   succeeded       Update autoscaling config               nokome@...        7m2s ago            

API

 mutation {
  updateAutoscaleConfig(input: {
    appId: "APP_NAME",
    enabled: false,
  }) {
    app {
      autoscaling {
        enabled
      }
    }
  }
}

returns

{
  "data": {
    "updateAutoscaleConfig": {
      "app": {
        "autoscaling": {
          "enabled": false
        }
      }
    }
  }
}

as expected, but then,

 query {
  app(name: "APP_NAME") {
    autoscaling {
      enabled
      strategy
    }
  }
}

returns

{
  "data": {
    "app": {
      "autoscaling": {
        "enabled": true,
        "strategy": "PREFERRED_REGIONS"
      }
    }
  }
}

Is this a bug, or am I missing something?