Failed deployment v96126 and counting - even though my app runs just fine

A while ago I played with some autoscaling settings and ever since then the “monitoring” tab tells me that the deployment failed:

It has been counting up for 2 weeks now. I thought it would just disappear by itself. Note that my app is working just fine!

I can’t recall the exact commands or configuration I was experimenting with, but at the very least I tried fly autoscale set min=1 max=10. I’ve tried disabling that through fly autoscale disable but it gives me the message that “Configuring autoscaling via ‘flyctl autoscale’ is supported only for apps running on Nomad platform”.

Anyway, this is mostly just a heads-up for any potential issues this may uncover, as the “counter” is not bothering me and I am currently not in need for actual autoscaling.

Here is my current config in case it is useful:

app = "ecobite-backend-staging"
kill_signal = "SIGINT"
kill_timeout = 5
mounts = []
primary_region = "ams"
processes = []

  image = ""

  QE_HOST = ""

  internal_port = 8080
  processes = ["app"]
  protocol = "tcp"
    hard_limit = 25
    soft_limit = 20
    type = "connections"

    force_https = true
    handlers = ["http"]
    port = 80

    handlers = ["tls", "http"]
    port = 443

You’re deploying machines, correct?

I hit the same thing running flyctl autoscale on a machine deployed application:

Ended up having to recreate my machine and never (ever) re-running flyctl autoscale on a V2 app.

Are you running a V2 app? If yes, it’s probably the same :slight_smile:


Thanks for the info! Didn’t find your thread before. I’m running a V2 app indeed. I’ll recreate it then!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.