An unknown error occurred?

I’m trying to deploy an Elixir/Phoenix app attached to a Postgres database and I’m getting “An unknown error occurred” when I try to attach the app to the database.

How can I resolve this issue? I’ve been able to deploy this app successfully in the past.

Well, I tried deploying again 10 minutes later and it worked, so I guess I’m good for now. But this makes me nervous because I don’t know why it works sometimes and doesn’t work sometimes.

Faced An unknown error occured just after attaching my first db to an app.

The attachment went well, but now I get the error for most postgres related commands, like:

  • flyctl pg db list db-tullo
  • flyctl pg users list db-tullo

These commands worked fine before I run flyctl pg attach --database-name foobar --postgres-app db-tullo

Any ideas?

Okay, I redeployed the app and after a few minutes the mentioned commands started to work again.
One has to run them twice as the initial execution will fail.

I’m also having this issue and I’ve given this a fresh launch of both app and db twice now. Can we please get some more error logging or something on this end if it’s us? Any tips?