Fly app Deployment stuck - status in error

– Update – Got it working! Here was some of the snags I hit in case it helps anyone

  • Followed the instructions on Deploying on Fly — Phoenix v1.6.6
  • when running fly postgres attach as mentioned in the steps I encountered the following error
  • From what I could deduce on forums this is an actual error with fly that is somewhat intermittent. Try rerunning the command to see if it succeeds
  • If the following error occurs
  • there are two options: 1) add the --database-user flag and specify a new user, or 2) destroy the database, recreate (with the --name flag if you want to preserve the name), and try the attach command again

After a few bouts of this happening it finally worked for me. Hope this helps someone

--------------------------------------- ORIGINAL QUESTION ----------------------------------------------

Hey! Ran into a deployment error when trying to deploy a fresh elixir/phoenix app. The postgres application associated with it seems to be running fine, but the elixir app stops at the log line shown (screenshot). I’ve let this sit overnight so I’m pretty confident it isn’t moving forward. Any help would be greatly appreciated!

How this happened

  • initted a new application with the latest (1.13.3) elixir version.
  • installed phoenix
  • I followed the instructions at Speedrun! Deploying to Fly!
  • The app doesn’t appear on my fly dashboard in the web interface, but the postgres instance seems to

What I’ve tried

  • I’ve been digging through Troubleshooting your Deployment to try and find out a way to isolate the problem
  • restarting the app via fly restart
  • destroying the app and recreating via fly destroy and then fly launch --name larded-muffin (the previous app name)
    This is all done in the free tier.

This is my first time really posting to any site for help… so whatever I can post here to help out with visibility just let me know. Thanks all!

1 Like