Cannot attach Postgres to new Elixir App

I had a previous app that run the production version indiepaper-prod with associated db indiepaper-prod-db. Since I rewrote it from scratch and effective number of people using the app was zero, I decided to delete them and deploy from scratch.

I created the new app indiepaper-prod and the new postgres database indiepaper-prod-db. Running fly postgres attach --postgres-app indiepaper-prod-db -a indiepaper-prod throws an unknown error occurred.

Things I have tried

  • Deployed to different regions
  • Change name to indiepaperme-prod and indiepaperme-prod-db respectively
  • Created a new account and tried deploying the same.

What seems to be the issue ? Or is it something on my side ?

@aswinmohanme I am taking a look!

1 Like

Feel free to recreate both indiepaper-prod-db and indiepaper-prod app if necessary.

@aswinmohanme I just pushed out something that should address the issue. Mind giving it another try?

1 Like

Yes, the issue is fixed and I successfully deployed the app. Thanks for being responsive and the quick fix :rocket:

1 Like

Perfect, glad to hear!

1 Like

I’ve just started with and I’m getting the same message:

Attaching...⣾ Error An unknown error occured.

I tried deleting and re-creating both the app and the db app with no luck. It’s a bit frustrating to see this issue as “solved” with no real explanation as to what was fixed and what might be happening behind the scenes.

Yea it’s broken again. For manual connection see here: An unknown error occurred? - #8 by shaun

1 Like


Should be fixed in flyctl version 0.0.263.

1 Like