Wireguard peer down in Amsterdam?

I tried connecting with wireguard to my usual Amsterdam based peer and it suddenly stopped working and I couldn’t connect to any private IPs (I noticed since the DNS stopped resolving any hosts). I tried restarting the tunnel and fiddling with the wg commands a bit, but couldn’t get it to work. I created a new wireguard profile that connected to Frankfurt instead and that worked fine. :man_shrugging:

If this isn’t an issue or if it is already fixed, go ahead and ignore this…

BTW, how do you usually prefer to get support related reports like this?

Did you delete the peer in Amsterdam by chance? Will you run fly wg list <org> and let me know if you still see it?

I did delete and recreate it several times just to verify and try to get it working.

Also, I DO have an ams peer in my flyctl wg list, even though I deleted them all.

You should be OK again. You’re catching the tail end of a migration we’re doing to a new system for managing WireGuard peers (as of tomorrow, it should take single-digit seconds to create and bring up WireGuard for a new peer, rather than 1.5 minutes).

I think you created and then deleted a peer, which snagged a corner case — I had a UNIQUE constraint on a sqlite column that the peer you’re talking about was hitting.

I’ve rolled back AMS to the old (slow) behavior (boo!) — it should be fine for you now.

Ah, great! Thanks for the answer and insight! No need to rollback on account of little me though, I’m fine working through the fra peer for now.

Nope! Everybody in AMS has to suffer. Because of YOU.

(Thank you for letting us know about this! It was going to bite us one way or the other; glad we got it early.)

1 Like

Haha,nooooo… Keep up the good work you are all doing!

This doesn’t happen to affect metrics collection by any chance…?

Never mind, it just took forever to start collecting metrics after I launched an app.

Nope. It should only have impacted newly-enrolled WireGuard peers.