Unable to deploy since 5h ago

I’m trying to push an update, but after 3 tries with a couple hours in between I can’t manage to deploy my there-nur service.

I also tried changing regions and hkg was also like this. My regions are fra,ams,iad,and hkg as of now.

looking

1 Like

CleanShot 2021-08-06 at 23.57.23

Please ping me as soon as I can deploy successfully.
Thanks for looking into it.

You can see updates here Fly.io Status - Errors launching VMs

@mo.rajbi This should now be resolved

1 Like

Not for me. I have an app in the iad and haven’t been able to deploy for the last few hours.
I noticed that the remote-builder app gets spunt up to but just hangs.
I have to run flyctl apps destroy “remote-app-builder” because it doesnt appear to get destroyed if the process terminates without actually deploying

When I run the call to check the logs…its a stream of container checks

1 Like

It doesn’t get destroyed because it gets reused to optimize the caching of Docker layers. We do shut it down after some time of inactivity. The checks logs are making sure we don’t shutdown the builder during a build.

@douglas Can you try again? It seems like something in the midst of the issues we had last night had repercussions in other regions.

That worked for one app owned by an organization but another app that is owned by personal wont connect to the remote builder. And fails immediately without hanging.

I’m also not able to deploy today.

I’m also having issues with deployments today. Flyctl just keeps hanging after docker push, and flyctl deploy never returns.

@Douglas That “unknown error” was a 500 from our API which should be fixed now. Could you try again? Also, do you have Docker running locally, maybe as another user on the system? The permission error is unexpected.

@gwilym are you still having issues?

@p112 are you still having issues? Could you post flyctl’s output?

@michael I’m still having the issue, in lhr zone. There’s not much to see on the flyctl output, it just hangs at a random point during docker build, then I can see that the builder is dead.

Could you run it like LOG_LEVEL=debug flyctl deploy ... and DM me the output?

Still not working unfortunately:

**Deploying fragrant-leaf-492**

==> Validating app configuration

--> Validating app configuration done

**Services**

TCP 80/443 ⇢ 8080

Waiting for remote builder fly-builder-broken-sound-9803...

Task Terminated with exit code 1

WARN Remote builder did not start on time. Check remote builder logs with `flyctl logs -a fly-builder-broken-sound-9803`

Error remote builder app unavailable

@gwilym we had a private DNS outage that might have caused this. Will you give it another try and see if it works now?

@michael I do have docker running on that box. Thats what I use to figure out how setup the fly.io deploy files. The 500 error appears to be fixed.

@michael I have just tried again, and successfully deployed!

Works now :slight_smile:

Everything in this topic has been resolved. I’m going to close it, if new issues come up feel free to post a new topic.