Unable to deploy app

I have an app that I was able to deploy without issues until about 6 hours ago. After that anytime I run fly deploy, it gets stuck on Sending build context to Docker daemon forever.

 ▲ fly deploy --remote-only
==> Verifying app config
--> Verified app config
==> Building image
Remote builder fly-builder-morning-sunset-6140 ready
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.12 linux x86_64
[+] Building 879.2s (0/1)
 => [internal] load remote build context                           879.2s
Sending build context to Docker daemon  1.067MB

So far, I’ve tried:

  • Deleting the builder
  • Changing the app region (from yyz to ewr and dfw)
  • Connecting to 3 different ISPs/networks
  • Redeploying a previously deployed commit/version

But it still does not work. The interesting thing is I can still deploy my other apps without issues like before. Note that in all this time, it only uploaded ~1MB above (however in multiple retries, sometimes it’s able to upload up to 5-7MB).

Any help would be appreciated as I have an urgent deploy that needs to go out! Thank you!

Does fly deploy --local-only works in your case? It’s not the same issue but I have random failures building the context. Probably the post Fly build hangs sending context to docker daemon ([internal] load remote build context timeout) is related to the issue.

Running fly deploy --local-only worked! Thanks!

This confirms for me that this is definitely an issue on Fly’s end for some regions/servers. Not sure why this app suddenly started facing this issue when a few other apps (across different orgs) I’ve tested are being deployed fine.

Update: Looks like both --remote-only and --local-only are working now.

Not sure what was the issue and which regions were affected though.