Unable to deploy after V2 migration.


Maybe someone on here can help with an issue I see today. I got a mail to say that my app was migrated to v2 a couple days ago and everything looked fine. Yesterday though I made some changes to the app and try to do a regular ‘fly deploy’. It failing to deploy though as its giving me the following error:

release_command d8d9349be64128 completed successfully
Updating existing machines in ‘blue-picasso’ with rolling strategy
[1/1] Updating 91851e1c472148 [app]
Error: failed to update VM 91851e1c472148: invalid config.mounts, only 1 volume supported

I have a entry in the fly.toml file for mounting a volume that worked fine before:
source = “app_data”
destination = “/data”

I feel like this must be something to do with the move to v2 but of course that could be just speculation on my part. As it is the previously deployed version keeps running but I would like to figure this out.

Anyone have any guidance on what might be happening here?

Thanks for your help

Edit: I have the latest CLI tool installed so I dont think thats an issue

I think you need [mounts], plural, or [[mounts]] if you have multiple volumes.

Sorry for the noise. Before redeploying, you may want to grab a copy of /data just in case this configuration didn’t in fact create a volume there. I’m not entirely sure why [mount] worked before and [mounts] is needed now, but we’ve had a couple instances where folks thought they were persisting data to a volume but were in fact writing it to a directory in the ephemeral rootfs.

I don’t immediately know how that might happen in this instance, so just take my old sysadmin paranoia for whatever it might be worth, which very well may be $0. :slight_smile:

Good luck, hope that helps.

1 Like

Thanks for the help nolan