Can't deploy all of a sudden - 'Mounts source volume "vol_" does not exist'

My Phoenix app usually is deployed via a github action.

name: Deploy to Fly Staging
      - main
    name: Deploy proxy
    runs-on: ubuntu-latest
      # This step checks out a copy of your repository.
      - uses: actions/checkout@v2
      # This step runs `flyctl deploy`.
      - uses: superfly/flyctl-actions@master
          FLY_API_TOKEN: ${{ secrets.FLY_API_TOKEN }}
          args: "deploy -a old-field-8878 --remote-only"

Have had very few problems with this. Sometimes it fails with a random error. Usually a rerun works, or worst case I destroy the builder app and try again and it works. This time I destroyed the builder app (fly destroy fly-builder-divine-breeze-779), and now I keep getting this error:

“Error failed to fetch an image or build from source: error connecting to docker: Mounts source volume “vol_” does not exist”

Happens both on the github action and if I try deploy locally. Seems busted.

My fly.toml:

kill_signal = "SIGTERM"
kill_timeout = 5
processes = []

  release_command = "/app/bin/migrate"

  PORT = "8080"

  allowed_public_ports = []
  auto_rollback = true

  http_checks = []
  internal_port = 8080
  processes = ["app"]
  protocol = "tcp"
  script_checks = []

    hard_limit = 1000
    soft_limit = 100
    type = "connections"

    handlers = ["http"]
    port = 80

    handlers = ["tls", "http"]
    port = 443

    grace_period = "1s"
    interval = "15s"
    restart_limit = 0
    timeout = "2s"

Ok I reran the job after waiting 30 mins and it worked again :man_shrugging:

I have this issue too in a GitLab runner. It happens with and without the --remote-only flag. Specifically, I run:

fly deploy --env PRODUCTION=true --region ams

inside an Alpine-based docker.

EDIT: It works locally so it’s a GitLab/Docker issue.
EDIT2: For sure not. Exactly the same code now runs (clicked re-run job in CI). It’s a issue.

Can you share the complete log? That particular error sounds like a bug.

Run superfly/flyctl-actions@master
    args: deploy -a old-field-8878 --remote-only
    FLY_API_TOKEN: ***
/usr/bin/docker run --name dc70ac1d45c044dd4bfaada936b198683_b977e6 --label 08450d --workdir /github/workspace --rm -e FLY_API_TOKEN -e INPUT_ARGS -e HOME -e GITHUB_JOB -e GITHUB_REF -e GITHUB_SHA -e GITHUB_REPOSITORY -e GITHUB_REPOSITORY_OWNER -e GITHUB_RUN_ID -e GITHUB_RUN_NUMBER -e GITHUB_RETENTION_DAYS -e GITHUB_RUN_ATTEMPT -e GITHUB_ACTOR -e GITHUB_WORKFLOW -e GITHUB_HEAD_REF -e GITHUB_BASE_REF -e GITHUB_EVENT_NAME -e GITHUB_SERVER_URL -e GITHUB_API_URL -e GITHUB_GRAPHQL_URL -e GITHUB_REF_NAME -e GITHUB_REF_PROTECTED -e GITHUB_REF_TYPE -e GITHUB_WORKSPACE -e GITHUB_ACTION -e GITHUB_EVENT_PATH -e GITHUB_ACTION_REPOSITORY -e GITHUB_ACTION_REF -e GITHUB_PATH -e GITHUB_ENV -e GITHUB_STEP_SUMMARY -e RUNNER_OS -e RUNNER_ARCH -e RUNNER_NAME -e RUNNER_TOOL_CACHE -e RUNNER_TEMP -e RUNNER_WORKSPACE -e ACTIONS_RUNTIME_URL -e ACTIONS_RUNTIME_TOKEN -e ACTIONS_CACHE_URL -e GITHUB_ACTIONS=true -e CI=true -v "/var/run/docker.sock":"/var/run/docker.sock" -v "/home/runner/work/_temp/_github_home":"/github/home" -v "/home/runner/work/_temp/_github_workflow":"/github/workflow" -v "/home/runner/work/_temp/_runner_file_commands":"/github/file_commands" -v "/home/runner/work/petal_marketing/petal_marketing":"/github/workspace" 08450d:c70ac1d45c044dd4bfaada936b198683 deploy -a old-field-8878 --remote-only
==> Verifying app config
--> Verified app config
==> Building image
Error failed to fetch an image or build from source: error connecting to docker: Mounts source volume "vol_" does not exist