Unable to connect to ssh for instance

My app keydb I can no longer ping over wireguard from my peers or get in via flyctl ssh. It shows as running, I even tried re-deploying and it went ok but same result. Any guesses?

It actually seems I cannot reach any of my apps using flyctl ssh…

Your WireGuard peer might be in a bad state. Can you open ~/.fly/config.yml and remove everything under wire_guard_state: and try again?

Are you connecting through Toronto by chance? We just fixed an issue where some wireguard peers weren’t enabled on a gateway in Toronto.

Yes, all our resources are in toronto and that will be where I am closest as well. Tried clearing out my local config.yml as suggested but no change, and my prod peer still can’t connect to apps either.

We discovered and corrected one more issue on that host, will you please try again?

This is a new kind of failure we think we can detect if it happens again, fwiw. These wireguard gateways have been basically bulletproof so far, it’s really helpful that you’re troubleshooting this with us.

Working now, thanks!

1 Like