Unable to access site or project


I currently cannot access my app at https://www.honeone.one or my app at https://django-projects.fly.dev.

Earlier today, my app was working. Then, I changed two DNS records to try to get the domain to work:

Type: A, Name: @, Data:
Type: CNAME, Name: www, Data: django-projects.fly.dev

The DNS servers refresh every hour and it has been a couple hours.

Took out CNAME for www, so I’m just using the A record with the IP address.

Ran ‘fly deploy’ per today’s Fly Platform Status.

It has an ERROR:

DNS checks failed: expected 1 A records for django-projects.fly.dev., got 0

Project link now works. Still unable to access domain - https://www.honeone.one

My domain host, GoDaddy, says they update DNS every hour, but maybe it takes a day or two for changes to propogate throughout the Net. I’ll check back in a day or two.

From my side, I can see honeone.one is point to the shared ipv4 fly.io provided, but www.honeone.one not, neither A nor CNAME.

Maybe there is something wrong with GoDaddy DNS, like not saved or typo (ww instead of www). Otherwise, switching to Cloudflare where DNS can take effect immediately may helps.

Thank you.

If honeone.one is pointed to the shared ipv4 fly.io provided, why am I unable to access the app via https://honeone.one?

As far as www.honeone.one not pointing, I think that’s because I got rid of the CNAME record for www. I just have the A record pointing to the IP address.

Any idea why https://honeone.one does not bring up my app?

Also, if I type in my IP address of, I am unable to get to the app directly (not using the domain name).

I will also look into Cloudfare in case I cannot get this resolved here.

Now using Cloudfare to manage DNS.

I have the following DNS records:
type, name, content
A, honeone.one,
AAAA, honeone.one, 2a09:8280:1::3a:b42b:0
CNAME, www, honeone.one

Unable to access http://honeone.one or
Can access django-projects.fly.dev

Unable to access http://www.honeone.one

Get error code 520. Problem seems to be somewhere between Cloudfare and GoDaddy.

What steps did you do to setup your CF? Try: Some requests are not reaching fly.io servers - #8 by khuezy

Thanks, I switched back to GoDaddy and am not using Cloudfare.

Unable to access http://www.honeone.one

Currently getting Error 1001 as it will probably take a little time for Cloudfare to update, but then I’m sure I’ll have trouble accessing the site via GoDaddy like before.

I have the following DNS records:
type, name, content
A, honeone.one,
AAAA, honeone.one, 2a09:8280:1::3a:b42b:0
CNAME, www, honeone.one


Now getting a Django error, so it’s getting to the app!

Error says DisallowedHost at /
Invalid HTTP_HOST header: ‘honeone.one’. You may need to add ‘honeone.one’ to ALLOWED_HOSTS. Will try that…

honeone.one works!
www.honeone.one doesn’t

Changed CNAME record to point to django-projects.fly.dev
Maybe www.honeone.one will work, but just takes Django time to update.

Hi @mbak000—have you tried adding a certificate for www.honeone.one as well? It might be a bit unintuitive, but it’s actually a distinct domain name that needs to be configured too.

It works now! Thanks Matthewlngwersen - adding that certificate seemed to do the trick!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.