Unable to access any fly.io resources (dashboard, and apps) via IPv6

When attempting to access any fly.io resource (except this forum) via IPv6, the connection times out.

Here is the relevant part of the traceroute:

 4  nyiix6.as36236.net  28.872 ms  20.688 ms  19.006 ms
 5  2607:f740:70:101::6  34.000 ms  33.906 ms  26.378 ms
 6  * *

No matter the resource, that’s where the traceroute times out.

My IPv6 provider is peered with HE.Net

Please let me know if I can provide any more details. Thanks :slight_smile:

Can you ping the IPv6 by chance?

I can indeed ping :thinking:

Ok, so, some more weirdness.

It seems that it is likely an issue on my end, as I’m able to curl -6 fly.io in the terminal, but still does not load in my browser (FF). So I tried chrome, and things load as expected. This means that the issue is with FF with IPv6 (on my machine at least). So I pop open about:config, and disable IPv6 and can load things. This of course is not the optimal solution, as IPv6 is the future™, so I set ipv4 only for fly.io specific domains. This still has issues with other fly apps using custom domains, but is suitable enough for the short term.

I’m currently using a mac, and have disabled private IP relay (even though this only affects safari & mail).

I’ve tried changing DNS servers to see if that changes things, but alas it does not.

So, I’m just going to leave this as an unsolved mystery as I have a (somewhat janky) workaround.