Sunsetting Nomad

@jaimeiniesta Can you please try updating your postgres image? fly image update -a <appname>

@sarawoods Your app was also misidentified as postgres. I’ve flipped the switch, you should be able to migrate!

1 Like

Done! But the migrate-to-v2 still fails with the same error message after that.

Hi i’m getting an error trying to update my postgres apps. It says the following

Creatings 2 new volume(s) in ‘fra’
failed while migrating: failed to create volume: Some of our regions require a paid plan, due to high demand (Regions · Fly Docs). You must have a paid plan to scale up in fra. Setup a plan here:

The problem is that i’m already paying and have a credit card associated to my account but i don’t want to choose a plan another plan, i prefer to keep paying as i go using the hobby plan since those are hobby projects anyway.

What should i do?

Hi I am trying to migrate my fly postgres instances to v2 (dronda-pg). When I run the command migrate-to-v2 it fails saying: Error: no instances found with leader role.

However when I type fly status, I see one of the instances is marked as a leader.

Any advice on how I should proceed? Thank you!


I am getting the following when trying to upgrade my mysql instance:

? Would you like to continue? Yes
==> Migrating course-management-mysql to the V2 platform

Locking app to prevent changes during the migration
Enabling machine creation on app
Creating an app release to register this migration
Starting machines
INFO Using wait timeout: 5m0s lease timeout: 13s delay between lease refreshes: 4s

Updating existing machines in ‘course-management-mysql’ with rolling strategy
Machine 6e82d61ef71d18 [app] has state: started
[1/1] Checking that 6e82d61ef71d18 [app] is up and running
Smoke checks for 6e82d61ef71d18 failed: the app appears to be crashing
Check its logs: here’s the last lines below, or run ‘fly logs -i 6e82d61ef71d18’:
failed while migrating: smoke checks for 6e82d61ef71d18 failed: the app appears to be crashing
? Would you like to enter interactive troubleshooting mode? If not, the migration will be rolled back. (Y/n)

@quentin Unfortunately, that region requires a plan. Note that the plans come with usage equivalent to the price, so if you pay over $29/mo there’s no downside to picking the Launch plan.
If you don’t want that (plenty of valid reasons to not want that!), you can find another region nearby and deploy to that instead.

We currently have remote volume forking disabled in flyctl, but I think we should be able to reenable that now. I’m going to check on that, because that would make moving things over to another region much easier.

@dronda Postgres apps have been difficult to migrate lately, there’s a regression in the migration command. I’ve been trying to debug this, but it’s proving difficult. Hang tight, we’ll update you when we have news to share.

@wisdom-b Your mysql instance seems to be crashing on boot. If you can, it might be helpful to try running it with the --verbose flag. If it’s an option, you could also try making a backup of your data (fly vol list to see volumes, and then fly vol fork to get a backup of the current volume), then upgrade the version of mysql in use?

1 Like