The Death Of Nomad

We’re ending support for Nomad apps today.

It’s been a long time coming, but it’s finally time to drop Nomad. We’ve been running automated migrations from our side and emailing anyone with unmigrated apps, but naturally, there are some apps that just didn’t get moved over. Today, we’re turning these apps off, while we work on scaling back our support for Nomad.

This means that:

  1. Apps still running on Nomad will be scaled down to zero VMs.
  2. These apps will be flipped over to Machines, but no new Machines will be created for them.
  3. Nothing will be deleted, and redeploying your app could be as easy as fly deploy (although some configurations might require a little more work to get things going again)

Thanks for sticking with us while we moved everything over. It’s been a long journey!

If your app is one of the unlucky few that couldn’t successfully migrate, this thread is the perfect place to look for some help getting things running again. Thanks!


Hey there, I got this email today:

Hi. We’re in the process of removing Nomad from This means any apps that haven’t been upgraded to Apps V2 will no longer function.

Your app memberscroll-db is one of those apps

I remember migrating to v2 a while ago. Even if I run fly migrate-to-v2 I get:

Error: the app 'memberscroll' is already on the apps v2 platform

For some reason, I can’t deploy. Getting this error: ActiveRecord::ConnectionNotEstablished: could not connect to server: Connection refused. I tried fly scale count 1 -a memberscroll-db and fly postgres attach --app memberscroll memberscroll-db Error: command is not compatible with this image but no luck. Any idea what’s going wrong?

I want to just take a database dump but there’s no way to access my database. I’ve tried following the steps on the external connection article and no luck – I just get

connection to server at "localhost" (::1), port 15432 failed: Connection refused

My app has been down for a day. Would appreciate any help @allison

The memberscroll app was migrated, but it looks like your postgres memberscroll-db app was still on Nomad on Nov 1st. Do you know what Postgres version you were using? If you received emails from us, it’s because we weren’t able to auto-migrate you, probably due to an outdated postgres image.

The fastest way to recover is to restore from a snapshot/backup. The command is something like this:

fly postgres create --name memberscroll-db-restored --vm-size [your VM size] --volume-size [your vol size] --initial-cluster-size 1 --region [your region] --org [your org name] --image-ref[your original PG version] --stolon --snapshot-id [Snapshot ID]

Let me know if you’re able to try that - if not we can try some other things but it will take longer.


Thanks @nina! This worked :tada: Back up and running now :slight_smile:

1 Like