Stuck deployment in iad - "EBUSY: Device or resource busy, retrying in a bit"

I’m running a small app in iad that got auto-deployed yesterday. That deployment timed out and seems to be stuck. The bottom of the “Monitor” tab’s log pane for deployment 426b3f78-72bf-1136-7ff9-64198481e5de says:

2022-12-27T23:03:51.606 app[927191be] iad [info] 2022/12/27 23:03:51 [info] 538#538: *18147 client closed keepalive connection
2022-12-27T23:03:51.615 app[927191be] iad [info] Starting clean up.
2022-12-27T23:03:51.616 app[927191be] iad [info] Umounting /dev/vdc from /var/lib/tailscale
2022-12-27T23:03:51.617 app[927191be] iad [info] error umounting /var/lib/tailscale: EBUSY: Device or resource busy, retrying in a bit

It doesn’t seem to have retried unmounting that volume in 22 hours, and nothing I do can kick off another deploy (tried scaling down and up - nothing happens). Can fly folks check what’s going on, there?

Aw damn, there’s a flyctl apps restart command that worked. Things are up again, everything’s resolved.

1 Like