Deployment started failing and the app is down.

I tried to deploy to fly. But it got stuck in “iad pending”.
The app is down now. And I can’t make it work anymore.

Deployment has always worked for us, but now it stopped working, and we didn’t do anything differently.

It’s stuck in “iad pending”

Have you made any changes to fly?
How can I fix this? My app has been down for more than 30 minutes now.
I’m a very worried.

ca1cd6da	app    	341    	iad   	run    	pending	1 total      	0       	13m41s ago


After 23 minutes, it deployed successfully.

I don’t know why this happened, as it usually takes less than 5 minutes.
I’m still worried. Will this happen again next time I deploy?

It looks like ca1cd6da is running just fine now. It looks like you did a rolling deploy, but your app only has one VM. This will take the original VM down before starting the new one.

Depending on our capacity at any given time, it can take some time to schedule a new VM.

It would be best to fly scale count 2 or more if you need more redundancy. Running a single instance app is a little risky.

1 Like

Hi, kurt.
Yes, it’s now working as expected.
And yes, you are right. We used to run 3 instances (iad, syd and lhr), but now we have 1.
We will change to 2 or more instances again.
Thanks for your reply!