Still not possible to connect to fly instances through ssh

I’m coming back to this issue after my previous one (Cannot ssh to server on windows) didn’t get any answer!

So. Is it even possible to connect to a fly instance through ssh on Windows? I even tried it on WSL and still get the dreaded:

flyctl ssh console
Connecting to tunnel ⣷

And it just hangs in there for ever. What am I doing wrong? What should I do? Is there a way to actually debug this thing? The --verbose flag does display aything more.

Please write a proper tutorial if something is missing from the docs. I have tried everything I could with my feeble knowledge but no luck.

Also I have to mention that other commands like fly deploy and fly logs work fine both from the windows cmd and wsl.

Finally, I need to add that after the previous problem I had with your docs (i.e Following the docs to create a static website) being completely wrong and out of sync of how the flyctl works I have lost almost all my trust for your service and especially the quality of the docs.

Kind regards,
Serafeim

@spapas Sorry your previous question didn’t get answered, I’ll try to figure this out and get back to you. I’m also joining the Fly team to handle problems like your questions getting missed out and the out-of-date docs, so you can tag me whenever you need help.

I’m not sure what the support level is for Windows, so this is going to take a little more time to handle than usual — the networking stack is completely different on non-unix OSes, so it’s a lot more work to test and support. Will come post again when I have more info to share, though.

2 Likes

Hello @sudhir.j thank you so much! You were really helpful with all your previous answers :slight_smile:

As I said everything I’ve tried else except fly ssh console seems to be working fine under windows. Maybe there’s some configuration that needs to be done in my computer that I don’t know about?

Notice that I was able to connect fine from a linux environment (however I have it only as a backup and do not use linux as my primary dev env). Also, I have the same problem from two windows 10 computers (at work and at home).

Kind regards and thank you again,
Serafeim

Yeah, the entire toolchain is different with Windows, and many tools like Go, Wireguard (which is what flyctl and the Fly networking stack are built on) have different levels of support for different versions under different patch levels. So it’s definitely possible that something weird is happening. Let me do some research on this and get back, though. Will probably have to buy a Windows machine or spin up a VM first :-/

1 Like

@spapas We don’t currently have support for the Windows ssh/console feature, unfortunately. I’ll try to update the docs to note this and will make an announcement if and when we do add support.

1 Like

Hello @sudhir.j thank you very much for researching this and clarifying the issue!

However I need to confess that I tried sshing using my Windows today just to try mu luck and it actually connected immediately! I hadn’t changed anything nor tried anything fancy from the other times. This is really strange to me and I feel very bad for wasting your time :frowning:

It would be great if there was a way to debug the ssh console commend i.e see what it does (because the --verbose option doesn’t display that much info).

Kind regards,
Serafeim

Yeah, I was mistaken, the answer is a bit more nuanced. flyctl ssh supports Windows, but a little differently from other unix based OSes, still haven’t wrapped my head around the difference.

Will raise an issue to improve the error / debug messages around this.

1 Like